We are currently investigating issues with Projects in our US region
Incident Report for Teamwork.com
Resolved
We believe the issue is related to some workloads consuming more than the expected amount of resources and have scaled the workloads accordingly. We are still investigating the exact root cause.
Posted Aug 16, 2023 - 22:41 UTC
Monitoring
The issue has been resolved. We are still investigating the root cause.
Posted Aug 16, 2023 - 21:09 UTC
Investigating
We are currently investigating issues with Projects in our US region.
Posted Aug 16, 2023 - 20:41 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).