Delayed processing of inbound mail in US region

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 17:22 UTC

Monitoring

The issue has been identified and resolved. New inbound mails are arriving as expected now. We are working to process the backlog of unhandled mail.
Posted Jun 26, 2025 - 16:51 UTC

Investigating

We are currently investigating an issue where inbound mail to Teamwork.com (Projects) is delayed.
Posted Jun 26, 2025 - 16:11 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).