Desk performance issues
Incident Report for Teamwork.com
Resolved
This incident has been resolved
Posted Apr 24, 2023 - 17:39 UTC
Investigating
We are currently investigating performance issues with Desk in both EU and US regions
Posted Apr 24, 2023 - 17:36 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).