We are investigating reports of poor performance in the US region
Incident Report for Teamwork.com
Resolved
Response times are stable in our US region, we are continuing to monitor for performance issues
Posted Jun 24, 2021 - 13:31 UTC
Identified
We are investigating reports of poor performance in the US region
Posted Jun 24, 2021 - 13:14 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).