Teamwork Desk - Inbound Mail Processing Service Interruption
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Aug 07, 2024 - 10:37 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 07, 2024 - 10:03 UTC
Monitoring
A fix was implemented and we are monitoring for results
Posted Aug 07, 2024 - 10:02 UTC
Investigating
We are currently investigating this issue.
Posted Aug 07, 2024 - 08:41 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).