We are currently investigating issues for Teamwork Desk in our EU region
Incident Report for Teamwork.com
Resolved
Our cluster maintenance wasn't the cause of this issue as expected, our routing service needed a restart to take in DNS changes to bring services back online.
Posted Jul 03, 2021 - 10:14 UTC
Identified
We have identified that new nodes coming online in our EU cluster after an upgrade are experiencing DNS issues. We are attempting to isolate the nodes and ensure new nodes are operating normally.
Posted Jul 03, 2021 - 09:43 UTC
Investigating
We are currently investigating issues for Teamwork Desk in our EU region
Posted Jul 03, 2021 - 09:10 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region).