We are experiencing delays in processing inbound emails in Desk

Incident Report for Teamwork.com

Resolved

Emails are back processing as normal now.
Posted Aug 13, 2020 - 15:57 UTC

Monitoring

The Desk team have deployed a fix and mail is processing again. Some messages may be delayed a little longer while the queue is processed, no messages have been lost. during this.
Posted Aug 13, 2020 - 15:26 UTC

Identified

We have identified the cause and the team are working on a solution
Posted Aug 13, 2020 - 14:37 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).