Delays processing email inboxes
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 21:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 15, 2020 - 20:30 UTC
Investigating
We are currently investigating a slow down in processing inboxes in Desk.
Posted Oct 15, 2020 - 19:55 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).