Email delivery

Incident Report for Teamwork.com

Resolved

The issue with email delivery is resolved.
All undelivered mail has been queued and will be delivered.
Posted Apr 16, 2025 - 22:45 UTC

Investigating

We are currently seeing issues with email delivery, we are investigating
Posted Apr 16, 2025 - 21:09 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region, Teamwork Desk - EU Region).