We are investigating reports of users unable to login in our US region
Incident Report for Teamwork.com
Resolved
A change in our routing has been deployed to fix the issue.
Posted May 21, 2020 - 09:29 UTC
Identified
We have identified the cause and we are deploying a fix
Posted May 21, 2020 - 09:23 UTC
This incident affected: Launchpad (Launchpad - US Region).