We are experiencing connectivity issues for Teamwork in our EU region
Incident Report for Teamwork.com
Resolved
We have bypassed the cause of the issue for now and performance has been stable for some time.
Posted Oct 12, 2021 - 10:48 UTC
Monitoring
Performance has stabilized and we are monitoring for further issues
Posted Oct 12, 2021 - 09:07 UTC
Identified
We are experiencing connectivity issues for Teamwork in our EU region
Posted Oct 12, 2021 - 08:44 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region).