We are investigating reports of Teamwork Desk - classic UI offline in our US region
Incident Report for Teamwork.com
Resolved
We have reverted back to an earlier deployment due to instability in our latest update for some customers who remain using the Teamwork Desk classic UI
Posted Nov 15, 2019 - 20:31 UTC
Investigating
We are investigating reports of Teamwork Desk - classic UI offline in our US region
Posted Nov 15, 2019 - 18:29 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).