We are investigating reports of slow response times for Teamwork in our US region
Incident Report for Teamwork.com
Resolved
We have resolved an issue that was impacting on Teamwork including Desk and Chat as we attempted to add more resource. Response times are returning to normal and we are monitoring for further issues.
Posted Jun 09, 2021 - 14:48 UTC
Update
We have restored normal operation for both Desk and Chat, we continue to work on Teamwork to restore normal functionality
Posted Jun 09, 2021 - 14:26 UTC
Update
We are also experiencing related issues with Chat and Desk in our US region
Posted Jun 09, 2021 - 13:34 UTC
Identified
We are investigating reports of slow response times for Teamwork in our US region
Posted Jun 09, 2021 - 12:26 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region), Teamwork Desk (Teamwork Desk - US Region), and Teamwork Chat (Teamwork Chat - US Region).