We are investigating reports of slow loading times for Teamwork Desk accounts in our US region
Incident Report for Teamwork.com
Resolved
Teamwork Desk have been restored to normal. There was an issue processing some unusual inbound email that has been resolved, both for now and any future occurrence.
Posted Oct 29, 2020 - 16:25 UTC
Investigating
We are investigating reports of slow loading times for Teamwork Desk accounts in our US region
Posted Oct 29, 2020 - 16:10 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).