We are currently seeing some issues with Desk and Teamwork - EU regions.
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Dec 03, 2021 - 13:51 UTC
Monitoring
We're currently monitoring the situation on Teamwork Desk and Teamwork in the EU regions.
Posted Dec 03, 2021 - 13:01 UTC
Investigating
We are currently investigating this issue.
Posted Dec 03, 2021 - 12:27 UTC
This incident affected: Teamwork Desk (Teamwork Desk - EU Region) and Teamwork Projects (Teamwork Projects - EU Region).