Customers using the custom domain proxy service in the US may experience intermittent errors.
Incident Report for Teamwork.com
Resolved
The error impacted less than 1% of customers using the custom domain proxy service.
Posted Jul 06, 2022 - 14:15 UTC
Update
We are continuing to investigate this issue.
Posted Jul 06, 2022 - 13:48 UTC
Investigating
We are currently investigating this issue.
Posted Jul 06, 2022 - 13:48 UTC