Investigating issues creating and cloning projects in the EU Region

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 21:31 UTC

Investigating

We are currently investigating this issue.
Posted Mar 24, 2026 - 20:41 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region).