We are currently investigating Desk connectivity issues in US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Oct 18, 2021 - 16:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2021 - 16:11 UTC
Investigating
We are currently investigating this issue.
Posted Oct 18, 2021 - 16:11 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).