We are currently completing some maintenance on a Search cluster in our US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Apr 23, 2022 - 13:27 UTC
Investigating
We are currently completing some maintenance on a Search cluster in our US region that has run longer than expected. While this migration is happening customers may have issues with in-app notifications, recent activities and search
Posted Apr 22, 2022 - 13:17 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).