High response times
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Jan 10, 2023 - 22:32 UTC
Monitoring
Remediation action has been taken and we are monitoring results
Posted Jan 10, 2023 - 22:10 UTC
Investigating
We are currently investigating high response times in our US region.
Posted Jan 10, 2023 - 21:29 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).