We are currently investigating issues with Projects in our US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted 24 days ago. Sep 26, 2019 - 08:16 UTC
Monitoring
One of our databases in the US region for Teamwork Projects was under significant load. We have stabilized the database for now and we will continue to monitor it.
Posted 24 days ago. Sep 25, 2019 - 23:05 UTC
Investigating
We are currently investigating issues with Projects in our US region
Posted 24 days ago. Sep 25, 2019 - 19:50 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).