US Projects affected

Incident Report for Teamwork.com

Resolved

Incident Resolved.
Posted Aug 10, 2023 - 16:13 UTC

Monitoring

Fix deployed - Monitoring
Posted Aug 10, 2023 - 15:46 UTC

Investigating

Investigating issues loading Projects and Tasks
Posted Aug 10, 2023 - 15:36 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).