We are investigating reports of issues logging in to new accounts in our EU region
Incident Report for Teamwork.com
Resolved
New accounts in our EU region are operating normally now. A database issue was undetected causing issues for replicating new account information. This has now been solved.
Posted Sep 16, 2020 - 10:03 UTC
Investigating
We are investigating reports of issues logging in to new accounts in our EU region
Posted Sep 16, 2020 - 08:54 UTC
This incident affected: Launchpad (Launchpad - EU Region), Teamwork Desk (Teamwork Desk - EU Region), Teamwork Projects (Teamwork Projects - EU Region), and Teamwork Chat (Teamwork Chat - EU Region).