We are currently investigating database connectivity issues in US region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 00:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2021 - 23:11 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 07, 2021 - 22:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 07, 2021 - 22:02 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region) and Teamwork Projects (Teamwork Projects - US region).