We are investigating instability of Teamwork services in our EU region
Incident Report for Teamwork.com
Resolved
This incident has been resolved.
Posted Oct 02, 2022 - 12:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 02, 2022 - 07:17 UTC
This incident affected: Teamwork Chat (Teamwork Chat - EU Region) and Teamwork Desk (Teamwork Desk - EU Region).