We are experiencing some connectivity issue for Teamwork Enterprise customers in our US region
Incident Report for Teamwork.com
Resolved
A damaged database has been bypassed now to return Teamwork Enterprise customers to normal operation
Posted May 15, 2021 - 04:14 UTC
Investigating
We are experiencing some connectivity issue for Teamwork Enterprise customers in our US region
Posted May 15, 2021 - 02:52 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).