Slowness on Teamwork Projects
Incident Report for Teamwork.com
Resolved
We have resolved an issue related to an increase in load at peak traffic
Posted Nov 28, 2022 - 23:04 UTC
Investigating
We are currently investigating this issue.
Posted Nov 28, 2022 - 19:05 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).