Degraded performance in our EU region
Incident Report for Teamwork.com
Resolved
Performance has returned to normal levels
Posted Sep 01, 2021 - 16:13 UTC
Monitoring
We received an unexpected volume of traffic in our EU region within a short period of time. We are handling the volume of traffic and performance is returning to normal. We will continue to monitor
Posted Sep 01, 2021 - 15:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 01, 2021 - 15:27 UTC
Investigating
We are currently investigating this issue.
Posted Sep 01, 2021 - 15:21 UTC
This incident affected: Teamwork Chat (Teamwork Chat - EU Region), Teamwork CRM (Teamwork CRM - EU Region), Teamwork Desk (Teamwork Desk - EU Region), Teamwork Spaces (Teamwork Spaces - EU Region), and Teamwork Projects (Teamwork Projects - EU Region).