We are investigating reports of custom domains issues in our EU region
Incident Report for Teamwork.com
Resolved
Our custom domain service in the EU is responding normally and we will monitor for issues.
Posted Feb 12, 2020 - 07:42 UTC
Investigating
We are investigating reports of custom domains issues in our EU region
Posted Feb 12, 2020 - 07:37 UTC
This incident affected: Teamwork Projects (Teamwork Projects - EU Region).