Problems with ticket send in Teamwork Desk

Incident Report for Teamwork.com

Resolved

This incident has been resolved.
Posted 18 days ago. Mar 21, 2025 - 19:47 UTC

Investigating

We are currently investigating this issue.
Posted 19 days ago. Mar 21, 2025 - 16:47 UTC
This incident affected: Teamwork Desk (Teamwork Desk - US Region).