we are investigating reports from users that tasks in Teamwork are not loading in our US region
Incident Report for Teamwork.com
Resolved
We have directed traffic away from a number of databases that were upgraded earlier this morning during our maintenance work.
Posted Jun 27, 2020 - 19:00 UTC
Investigating
We are currently investigating this issue.
Posted Jun 27, 2020 - 18:25 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region).